Tagi:

AutorWątek: Błąd po instalacji  (Przeczytany 3076 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline Pawcio714

  • czysty jak zad źrebaka
  • *
  • Wiadomości: 5
  • Brud/Czysty: +0/-0
Błąd po instalacji
« dnia: 25 Marzec , 2012, 10:40:20 am »
Witam, może ktoś doradzi co z tym zrobić. Jak tylko wyszedł jguardian to za pierwszym razem instalka poszła bez problemów i wszystko śmigało że aż miło ale po ostatnim update, zamiast zrobić update to wywaliłem wszystko ze strony i chciałem od nowa zainstalować, lecz przy instalacji jest problem z tworzeniem tabel w bazie danych a jak zaimportuję bazę danych którą miałem dotychczas to zamiast menu z lewej strony wywala mi taki błąd:

MYSQL ERROR:
1054: Unknown column 'grupa' in 'field list'


Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /home/nazwa serwera hostingu/public_html/jguardian/class/baza.class.php on line 35

Ktoś wie w czym problem ?

Offline wiciu

  • Administrator
  • śmierdzący zgnilizną brudas
  • *****
  • Wiadomości: 17093
  • Wypił browarów: 34
  • Brud/Czysty: +980/-661
  • Admin
    • G4Gwiciu
    • Mój stan Xfire
    • G4G -> Gracze dla graczy
Odp: Błąd po instalacji
« Odpowiedź #1 dnia: 25 Marzec , 2012, 11:25:14 am »
No wie wie..
w jguardian.sql był "," zamiast ";"
Pociągnij jeszcze raz instalkę i będzie okej.
Aha.. najpierw wyczyść bazę z tego co tam się częściowo doinstalowało.


Offline Pawcio714

  • czysty jak zad źrebaka
  • *
  • Wiadomości: 5
  • Brud/Czysty: +0/-0
Odp: Błąd po instalacji
« Odpowiedź #2 dnia: 25 Marzec , 2012, 11:45:21 am »
Ok dzięki za pomoc, instalka poszła ale przy importowaniu bazy danych wywala błąd:

Błąd

Zapytanie SQL:

--
-- Zrzut danych tabeli `bodyparts`
--
INSERT INTO `bodyparts` ( `id` , `server_type_id` , `body_part` , `body_part_long` )
VALUES ( 1, -1, 'HEAD', 'Head' ) , ( 2, -1, 'UPPER_TORSO', 'Upper Torso' ) , ( 3, -1, 'LOWER_TORSO', 'Lower Torso' ) , ( 4, -1, 'LEFT_ARM', 'Left Arm' ) , ( 5, -1, 'RIGHT_ARM', 'Right Arm' ) , ( 6, -1, 'LEFT_HAND', 'Left Hand' ) , ( 7, -1, 'RIGHT_HAND', 'Right Hand' ) , ( 8, -1, 'LEFT_LEG', 'Left Leg' ) , ( 9, -1, 'RIGHT_LEG', 'Right Leg' ) , ( 10, -1, 'LEFT_FOOT', 'Left Foot' ) , ( 11, -1, 'RIGHT_FOOT', 'Right Foot' ) , ( 12, -1, 'ALL', 'Body' ) ;

MySQL zwrócił komunikat: Dokumentacja
#1062 - Duplicate entry '1' for key 'PRIMARY'

Zapewne jeszcze w tej tabeli trzeba zmienić "," na ";"
« Ostatnia zmiana: 25 Marzec , 2012, 11:48:43 am wysłana przez Pawcio714 »

Offline wiciu

  • Administrator
  • śmierdzący zgnilizną brudas
  • *****
  • Wiadomości: 17093
  • Wypił browarów: 34
  • Brud/Czysty: +980/-661
  • Admin
    • G4Gwiciu
    • Mój stan Xfire
    • G4G -> Gracze dla graczy
Odp: Błąd po instalacji
« Odpowiedź #3 dnia: 25 Marzec , 2012, 11:47:49 am »
MySQL zwrócił komunikat: Dokumentacja
#1062 - Duplicate entry '1' for key 'PRIMARY'

To pokazuje że importujesz coś coś już masz w tabeli. 
Robisz to mechanicznie widzę.

Nie przenoś tabel
bodyparts
gamemodes
maps
panel_menu
plugin_admin_commands
plugin_censor_words
weapons
Czyli te które de facto są już dostarczane jako wypełnione w instalce.


« Ostatnia zmiana: 25 Marzec , 2012, 11:53:29 am wysłana przez wiciu »

Offline Pawcio714

  • czysty jak zad źrebaka
  • *
  • Wiadomości: 5
  • Brud/Czysty: +0/-0
Odp: Błąd po instalacji
« Odpowiedź #4 dnia: 25 Marzec , 2012, 11:50:29 am »
czyli nie mogę zaimportować kopi bazy danych z poprzedniej instalacji ?

Offline wiciu

  • Administrator
  • śmierdzący zgnilizną brudas
  • *****
  • Wiadomości: 17093
  • Wypił browarów: 34
  • Brud/Czysty: +980/-661
  • Admin
    • G4Gwiciu
    • Mój stan Xfire
    • G4G -> Gracze dla graczy
Odp: Błąd po instalacji
« Odpowiedź #5 dnia: 25 Marzec , 2012, 11:54:15 am »
czyli nie mogę zaimportować kopi bazy danych z poprzedniej instalacji ?
MOżesz to zrobić patrz wyżej.. edytowałem posta.
Ale musisz to zrobić mądrze. :)

Po to był plik updatu by nie było takich jaj,  jak masz teraz.

Offline Pawcio714

  • czysty jak zad źrebaka
  • *
  • Wiadomości: 5
  • Brud/Czysty: +0/-0
Odp: Błąd po instalacji
« Odpowiedź #6 dnia: 25 Marzec , 2012, 11:59:15 am »
ok rozumiem, jakoś to ogarnę, dzięki za pomoc

Offline Ashtonashlee0

  • czysty jak zad źrebaka
  • *
  • Wiadomości: 1
  • Brud/Czysty: +0/-0
    • aaaaa
    • Mój stan Skype
    • aaaaa
    • Mój stan Xfire
Odp: Błąd po instalacji
« Odpowiedź #7 dnia: 25 Styczeń , 2014, 07:51:04 am »
Proszę o określenie sposobu jak włączyć lub wyłączyć Pluginy.
Pytanie czy wystarczy usunąć jedną z linijek pluginu by przestał działać ???
cisco ccna certification cisco ccna certification       
link link

Offline wiciu

  • Administrator
  • śmierdzący zgnilizną brudas
  • *****
  • Wiadomości: 17093
  • Wypił browarów: 34
  • Brud/Czysty: +980/-661
  • Admin
    • G4Gwiciu
    • Mój stan Xfire
    • G4G -> Gracze dla graczy
Odp: Błąd po instalacji
« Odpowiedź #8 dnia: 03 Luty , 2014, 11:52:07 am »
Szczerze odradzam używania.
Porzuciliśmy ten projekt.. nie dawałem rady tego ciągnąć
Wiem że to działa.. ale supportować nie mamy już zamiaru.
Do jguardiana jest skandalicznie mało wtyczek.